Pazartesi , 25 Haziran 2018
Ana sayfa » WordPress » WordPress Cannot modify header hatası

WordPress Cannot modify header hatası

1 Puan2 Puan3 Puan4 Puan5 Puan 1 Kişi oy verdi Ortalama puan: 5,00.
Loading...

WordPress kurulumlarında sıkça yaşanan hatalardan biri olan

Warning: Cannot modify header information – headers already sent by (output started at …wp-includewp-config.php:1) in …wp-includespluggable-functions.php on line 272

hatasını alıyorsanız. WordPress sisteminizi çökmüş olarak görüyorsunuz demektir. Bu hatayı alma sebebinizde çözümü de çok basit. Forumlarda bu konu tartışma sebebi olmuş yüzlerce çözüm yolu getirilmiş ama hiç birine gerek yok.

Cannot modify header wordpress hatasının temel sebebi notepad gibi bir düzenleyici ile wp-config dosyasını yada her hangi bir wordpress sayfasını düzenlemiş iseniz , dosyanın en başına UTF-8 imzası (BOM) ekleniyor. Notepad de Utf-8 diye kaydetseniz bile bom seçeneği ekleniyor.
Doğal olarak bom kodlaması anlamsız karakterler gibi gözükmesine yol açtığı php dosyasını yorumlayamıyor ve dosya.php:1 hatasını alıyorsunuz.

WordPress cannot modify header information kurulum hatasının çözümü
Wordpress dosyalarından her hangi birini düzenlerken yada düzenlemişseniz bu düzenlediğiniz dosyayı tekrar Notepad ++ yada Edit Plus gibi bir php editör ile açarak farklı kaydet deyip daha sonrada Utf 8 olarak kaydetmeniz. Bu seçenek kimi ediöterlerde “BOM olmadan UTF-8″ ,   “İmzasız UTF-8″ şeklinde yer alabilir.

Benim size tavsiyem php dosyalarını editlerken Notepad ++ Yada Editplus programını kullanmanız.

Bunuda okumalısın !  Wordpress için en iyi robots.txt
BU YAZILARI DA MUTLAKA OKUYUN -----------------------------------------------------

İsterseniz bunları okuyun !

Haber sitesi için wordpress teması

Haber siteleri için wordpress teması internette oldukça aranan popüler kelimelelerden biri. Bizde bu boşluğu doldurmak adına …

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir